Internet Explorer 8

Please note that Internet Explorer 8 will not provide an optimal viewing experience at Hi5 Websites.  The reason is we use advanced CSS features only found in Internet Explorer 9 & 10, Firefox 16 and above, Safari 6 and above and Chrome 22 and above.

Pleaes click here to upgrade your Internet Explorer version to the most recent. It will provide greatly enhanced security and keep a LOT of those malware bugs out of your system.